Aptikta nauja grėsmė Apple kompiuterių vartotojams

Aptikta didelė saugumo spraga grasinanti naudojantiems Apple Mac ir Linux operacinės sistemos pagrindu veikiančius kompiuterius ir ekspertų teigimu ji yra kur kas pavojingesnė nei Heartbleed.

Shellshock klaida padaro pažeidžiamą „Bash“ - komandinę eilutę kontroliuojančią daugumą Unix operacinės sistemos pagrindu veikiančiuose kompiuteriuose esančią programinę įrangą. Komandinė eilutė yra integruota į kompiuterių veikimo operacijas ir naudojama eilėje veiksmų, tokių kaip aplikacijų atidarymas. Shellshock klaida atakuotojui suteikia galimybę nuotoliniu būdu valdyti kompiuterį.

„Tai sąsaja kurios pagrindu kompiuteryje kas nors vykdoma“. Vargu ar egzistuoja Linux sistema, kurioje nenaudojamas Bash“, - sakė Ernest Hilbert, buvęs FTB agentas ir kibernetinių nusikaltimų tyrimų skyriaus EMEA regionui vadas.

Shellshock klaida yra pavojingesnė nei balandį aptikta Heartbleed aptikta OpenSSL programinėje įrangoje skirtoje šifruoti paslaugų ar kompiuterio tarnybų perduodamus duomenis. Heartbleed leido užvaldyti vartotojo duomenis (pvz. skirtus prisijungti prie kokios nors tarnybos) ir su jais daryti ką tik nori, tačiau Shellshock saugumo spraga suteikia galimybę užpulti OS X ir Linux operacinių sistemų pagrindu veikiančius kompiuterius, juose įdiegti kenkėjišką programinę įrangą ir jos pagalba tuos kompiuterius valdyti nuotoliniu būdu.

Šių sistemų vartotojai turi kuo greičiau įdiegti visus atnaujinimus, o atsakingi už šių atnaujinimų išleidimą tuos atnaujinimus išleisti. Red Hat ir Ubuntu jau išleido saugumo atnaujinimus panaikinančius šią saugimo spragą, tačiau OS X vartotojams belieka laukti, kol jų saugumu pasirūpins Apple (tikėkimės nereikės laukti pusės metų ir kokio nors skandalo, kad Apple pagaliau pajudintų savo nuo pinigų pertekliaus aptingusius užpakalius).

Dabar, kai apie šią saugumo spragą paskelbta viešai - programišiai tuojau pat suskubs ieškoti galimybių ja pasinaudoti ir jie tikrai išsiaiškins kaip ši spraga veikia ir pabandys ją priversti dirbti jiems.

Kol Apple ruošia atnaujinimą

Jei norite patikrinti ar jūsų sistema turi šią Shellshock klaidą, atidarę terminal aplikaciją joje parašykite:

env x='() { :;}; echo pažeidžiama' bash -c 'echo labas'

Jei sistema pažeidžiama, įvedę aukščiau esančią komandą ir paspaudę Enter ↲ ekrane po ja pamatysite:

pažeidžiama
labas

Jei kam nukopijavus komandą ir įklijavus ją į Terminal'ą rašys unexpected token `(‘ - pabandykite komandą perrašyti rankomis. Taip gali nutikti dėl to, kad internete rodomi kai kurie simboliai gali būti iškraipyti. Visos viengubos kabutės komandoje yra apostrofo simbolis, kurį daugelis ras savo klaviatūrose ant to pačio klavišo ant, kurio yra ir angliškos kabutės.

Jei sistema nepažeidžiama paspaudę Enter ↲ Terminal lange turėtumėte matyti kažką panašaus į:

bash: warning: x: ignoring function definition attempt
bash: error importing function definition for `x’
labas

Šiuo metu naujausioje OS X Mavericks naudojama bash versija 3.2.51(1)-release (x86_64-apple-darwin13)

Patikrinti, kokia versija yra įdiegta pas jus galite Terminal aplikacijoje įvedę komandą:

bash --version

ir paspaudę Enter ↲

Jei po įvesta komanda Terminal aplikacijoje pamatysite

GNU bash, version 3.2.51(1)-release (x86_64-apple-darwin13)
Copyright © 2007 Free Software Foundation, Inc.

vadinasi sistema naudoja pažeidžiamą bash versiją

Tie, kas supranta ką čia rašau bei turi savo Mac kompiuteriuose įdiegę Xcode, gali perkompiliuoti bash versiją ir užtaisyti saugumo spragą patys, nelaukdami kol Apple teiksis ją užlopyti savo OS X vartotojams.

Tie, kas nesupranta ką daro komandos esančios žemiau - geriau nepradėkite savarankiškai improvizuoti, nes gali tekti patikrinti savo „system disaster recovery“ plano patikimumą ;)
Palaukite kol Apple išleis saugumo atnaujinimą.

$ mkdir bash-fix
$ cd bash-fix
$ curl https://opensource.apple.com/tarballs/bash/bash-92.tar.gz | tar zxf -
$ cd bash-92/bash-3.2
$ curl https://ftp.gnu.org/pub/gnu/bash/bash-3.2-patches/bash32-052 | patch -p0 
$ cd ..
$ sudo xcodebuild
$ sudo cp /bin/bash /bin/bash.old
$ sudo cp /bin/sh /bin/sh.old
$ build/Release/bash --version # GNU bash, version 3.2.52(1)-release
$ build/Release/sh --version   # GNU bash, version 3.2.52(1)-release
$ sudo cp build/Release/bash /bin
$ sudo cp build/Release/sh /bin

Po šių veiksmų, bash versija turėtų būti 3.2.52

GNU bash, version 3.2.52(1)-release (x86_64-apple-darwin13)
Copyright © 2007 Free Software Foundation, Inc.

Saugumo vardan, po testavimo rekomenduočiau senai versijai padaryti chmod -x arba ją perkelti prie atsarginių duomenų kopijų, tam kad užsitikrinti, kad ji nebus panaudota.

Apple, apie Shellshock klaidą sako, kad ji ruošia atnaujinimą šiai klaidai ištaisyti ir pamini, kad dauguma OS X vartotojų nėra paveikti šios saugumo spragos, nebent jie savo kompiuteriuose yra sukonfigūravę papildomus, pažangius Unix servisus. Apple nemini kokie būtent yra tie pažangūs Unix servisai bei nesako, kada atnaujinimas bus išleistas.

2014/09/30 Apple išleido „Shellshock“ saugumo spragą užlopantį atnaujinimą skirtą OS X Mavericks, OS X Mountain Lion ir OS X Lion.

Įdiegę atnaujinimą, Terminal aplikacijoje patikrinę bash versiją

bash --version

turėtumėte gauti

GNU bash, version 3.2.53(1)-release (x86_64-apple-darwin13)
Copyright © 2007 Free Software Foundation, Inc.

Apie Ramūnas Blavaščiūnas

Fotografijos, geros technikos ir kavos mylėtojas

Komentarų: 7 | Ačiū, kad rašote lietuviškai

  1. Kazkodel suvedus komanda patikrinimui ar pazeidziama, gaunu -bash: syntax error near unexpected token `('

    • Kartais internete rašomos komandos neteisingai rodo ' ir ` simbolius. Dabar pataisiau atgal iš chr'ų bet jei mes klaidą nukopijavus - geriausia jas Terminalo lange įrašyti ranka patiems. Visos viengubos kabutės yra simbolis, kurį daugelis ras netoli Enter klavišo, ant to pačio klavišo kuris naudojamas norint įvesti ir angliškas dvigubas kabutes.

  2. pas mane parašė, kad pažeidžiama :(

  3. dėt anti virusinę dabar reiks ?

  4. Pažeidžiama :( Apple, aūūūūū, greičiau lopyk :)

    • Reikia manyti Apple užlopys. Daugumai paprastų vartotojų dėl šito nevertėtų jaudintis, nebent savo kompiuteriuose jie naudoja SSH paslaugoms prieinančioms prie interneto (pvz web serverius) arba yra sukonfigūravę SSH „Remote login“ arba naudoja SSH, kad per group policy prisijungti prie enterprice serverių.
      Žinoma, yra ir tokių vartotojų, bet jų nėra dauguma.
      Jei norite tikrai būti saugūs, kol Apple neužtaisė spragos nuimkite visas varneles: System Preferences > Sharing nuststymuose.

Parašykite komentarą

Į viršų